Add routes.IgnoreRoute to readme

May 10, 2009 at 7:51 PM

Hi there,

I am looking at this MSM thing I like it so far.

One thing though: please add "Add this route instruction routes.IgnoreRoute("CombineScriptHandler.aspx/{*pathInfo}"); to RegiserRoutes method in global.asax.cs" to documentation. Otherwise people will loose time figuring out why handler is 404-ed.

Coordinator
Jun 4, 2009 at 11:34 PM

Thanks for reporting the issue. The document has been updated with new instructions.

Oct 13, 2009 at 12:56 PM

This is not the only missing in documentation.

There must be an additional entry in web.config if you get 404 Not Found error for /CombineScriptHandler.aspx?****

<page>

..............

<httpHandlers>

...........

<add verb="*" path="CombineScriptHandler.aspx" validate="false" type="MvcScriptManager.CombineScriptHandler, MvcScriptManager, Version=1.0.0.0, Culture=neutral, PublicKeyToken=6eb4f344e8972dc6"/>

</httpHandlers>

</page>

Coordinator
Oct 27, 2009 at 5:11 AM

This was in the Readme doc. I have now highlighted these out in case somebody missed it.

 

May 18, 2010 at 9:55 PM

There is a bit more clarification required on setting up the handler to work properly.

 

 

 

There are 2 portions in the web.config that are needed (Notice the slightly different syntax and "system.web" vs "system.webServer"

 

 

 

One is:

 

<system.web>
   <httpHandlers>
      <add verb="*" path="CombineScriptHandler.aspx" type="MvcScriptManager.CombineScriptHandler, MvcScriptManager, Version=1.0.0.0, Culture=neutral, PublicKeyToken=6eb4f344e8972dc6"/>
      ...
   </httpHandlers>
   ...
</system.web>

The other is:

 

  <system.webServer>
    <handlers>
      <add name="CombineScriptHandler" verb="*" path="CombineScriptHandler.aspx" preCondition="integratedMode" type="MvcScriptManager.CombineScriptHandler, MvcScriptManager, Version=1.0.0.0, Culture=neutral, PublicKeyToken=6eb4f344e8972dc6"/>
      ...
    </handlers>
    ...
  </system.webServer>
Mar 9, 2011 at 2:49 PM

I have everything in the readme in my web.config, and the system.webServer one mentioned here, but I am still getting 404 errors on /CombineScriptHandler.aspx.  I put the dlls in the bin directory and added references to them.  I also have 
routes.IgnoreRoute("{resource}.axd/{*pathInfo}"); in my global.asax.cs file in RegisterRoutes.  I'm not sure what I am missing.